'SearchBoxEx' and 'DropDownModesEx' types not found

Mar 25, 2011 at 12:31 PM
Edited Mar 25, 2011 at 12:34 PM

Hi all,

I'm trying to use the ESP WebParts with SharePoint 2010, but found a problem when trying to compile it (since the regular setup does not work with SP2010 I have to recompile the solution, but if anyone has a better suggestion I'm all ears).

I get the six following errors when trying to build the solution:

  • Error 1 The type name 'SearchBoxEx' could not be found. This type has been forwarded to assembly 'Microsoft.Office.Server.Search, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'. Consider adding a reference to that assembly. ESPAutoCompleteSearchBox.cs L=14 C=45
  • Error 2 The type name 'SearchBoxEx' could not be found. This type has been forwarded to assembly 'Microsoft.Office.Server.Search, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c'. Consider adding a reference to that assembly. ESPSearchBox.cs L=17 C=33 
  • Error 3 The type or namespace name 'DropDownModesEx' could not be found (are you missing a using directive or an assembly reference?)  ESPSearchBox.cs L=37 C=20 
  • Error 4 The type or namespace name 'DropDownModes' could not be found (are you missing a using directive or an assembly reference?)  ESPSearchBox.cs L=53 C=20
  • Error 5 The type or namespace name 'DropDownModesEx' could not be found (are you missing a using directive or an assembly reference?) ESPAutoCompleteSearchBox.cs L=139 C=20
  • Error 6 The type or namespace name 'DropDownModes' could not be found (are you missing a using directive or an assembly reference?) ESPAutoCompleteSearchBox.cs L=155 C=20

I'm using the latest release of the project "espwebparts-25734" and Visual Studio 2010.

Did anyone get this same problem or have any clue on how to fix it? I found this article about using ESP WebParts with SP2010 and already removed the Unit Tests project from the solution, so probably it is no the problem.

 

Thanks in advance,

Neo