Navigator mapping question?

Aug 28, 2008 at 7:50 PM
In the TR7 ESP Web Parts Demo the presenter used two fields. i.e. Company  and Industry

I tried to simulate the same thing in my environment. But when i click any of the Navigator like  company(Microsoft)  i am seeing all the companies like Google, IBM along with microsoft in the search result source field. It looks like my mapping is not correct. How do we fix that?

In my current ESP profile XML i have the following entries added
<field name="source" separator="#"/><field name="industry" separator="#"/>

<string-navigator name="sourcenavigator" display="Source"><field-ref name="source"/></string-navigator>
<string-navigator name="industrynavigator" display="Industry"><field-ref name="industry"/></string-navigator>

Following XML file mapped for the AttributeMapper
<attribute-mapping>
  <map from="companies" to="source"/>
  <map from="Gartner" to="Source"/>
  <map from="Vorsite" to="Source"/>
  <map from="Cap Gemini" to="Source"/>
  <map from="Accenture" to="Source"/>
  <map from="BearingPoint" to="Source"/>
  <map from="Coca-Cola" to="Source"/>
  <map from="Microsoft" to="Source"/>
  <map from="IBM" to="Source"/>
  <map from="Financial Services" to="industry"/>
  <map from="Government" to="industry"/>
  <map from="Media &amp; Entertainment" to="industry"/>
  <map from="Life Sciences" to="industry"/>
  <map from="Foods" to="industry"/>
  <map from="Education" to="industry"/>
  <map from="Communications" to="industry"/>
  <map from="Retail" to="industry"/>
  </attribute-mapping>